The easiest way to integrate Social Login in your React Apps ...Checkout NPM

Tuesday, November 13, 2012

Error while enabling windows feature NetFx3

Recently, I tried to install SQL 2012 express edition on a Windows 8 OS running inside VMware. Installation wizard is very much the same as SQL 2008, so I thought it's going to be pretty smooth. With several Next clicks, my installation process started. BUT :( it got aborted with following error:

The following error has occurred:
Error while enabling windows feature : NetFx3, Error Code : -2146498298.

Installation process requires .NET framework 3.5, which is generally not installed along with windows. However, it is available in Turn Windows Features On/Off option. Most likely this will be unchecked if you are getting NetFx3 installation error.

You'd be tempted to quickly check and try install this component. It shows 2 options - Install from a disc or install from internet. If you try later option, it will fail (I don't know reason but you'd see a generic error message). Check following resolution for an alternative workaround (which worked for me like a charm)

Open Command Prompt in elevated permission mode and execute 
dism /online /enable-feature /featurename:NetFx3 /source:d:\sources\sxs

Following is a Step-by-Step Guide:

1. Press Ctrl+Esc in windows 8 (or the hidden start button option in bottom left corner) to reach tiles screen
2. Righ Click anywhere in empty space to view "All Apps" option. Click on "All Apps" icon.
3. Once you select "All Apps", Windows8 will display icons of all apps installed. You may need to scroll horizontally to view Command Prompt. Once you find it, Right click on "Command Prompt" and from the options that appear at bottom, select "Run as Administrator".

 4. Once your command prompt opens, paste the command and hit enter. It will take a while and would actually look stuck at around 65% or so... Be patient, it should get 100% successfully installed.

That's it!!!!!
Try installing SQL 2012 Express again, and this time it will install without that nasty NetFx3 error.

No comments :

Post a Comment

What are your thoughts on this post? Did you like it?